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Atmel AVR 8-bit Microcontroller

AT12489: Getting Started with Atmel ATtiny102
and ATtiny104

APPLICATION NOTE

Description

This application note is for getting started with the Atmel® ATtiny102/104
AVR® based microcontroller.

The Atmel ATiny102/104 is a low-power CMOS 8-bit microcontroller based
on the AVR enhanced RISC architecture. By executing powerful instructions
in a single clock cycle, ATiny102/104 achieves throughputs close to 1 MIPS
per MHz. This empowers the system designer to optimize the device for
power consumption versus processing speed.

Features

*  Getting started with the ATtiny102/104 microcontroller and tools.

*  Getting started with Atmel ATtiny104 Xplained Nano Kit and Atmel
Studio 7.

This application note contains a list of all tools required to start using
ATtiny102/104 and provides references for additional information.
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1. Getting Started with Atmel ATtiny102 and ATtiny104

1.1. Key Features

AVR (Harvard) Architecture

Single Level Pipelining

In-system Reprogrammable Flash Memory

12 MIPS throughput at 12MHz

Most Single Clock Cycle Execution

High Code Density (Advanced RISC Instruction Set)
Programmable Supply Voltage Level Monitor with Interrupt and Reset
Low Power MCU with various Sleep Modes
Accurate Internal Calibrated Oscillator

Fast and Normal Start-up Time Options

Security with Fuses and Lock Bits

Compatibility between devices (portability)

Note: For more information about ATtiny102 and ATtiny104, refer to the device datasheet.

1.2. Device Related Website Links
The ATtiny102/104 product webpages are available at the following links:

ATtiny102: http://www.atmel.com/devices/ATTINY102.aspx

ATtiny104: http://www.atmel.com/devices/ATTINY 104.aspx

Atmel
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http://www.atmel.com/devices/ATTINY102.aspx
http://www.atmel.com/devices/ATTINY104.aspx

Figure 1-1. Device Webpage

Overview Parameters

Tools

Applications

between 1.8-5.5 volts.

By executing powerful instructions in a single clock cycle, the device achieves

The high-performance Atmel® tinyAVR(E picoPower® 8-bit RISC-based
microcontroller (MCU) combines 1KB in-system programmable Flash memory, 32
bytes SRAM, 12 general-purpose I/0 lines, 16 general-purpose working registers, one
16-bit timer/counters with two PWM channels, internal and external interrupts, an 8-
channel 10-bit &/D converter, on-chip analog comparator, one full duplex USART,
programmable watchdog timer with internal oscillator, internal calibrated oscillator, 10-
bytes unique 1D (serial number), three calibrated internal voltage references (1.1V,
2.2V and 4.3V), and four software selectable power saving modes. A version with
faster startup time is available under a dedicated part number. The device operates
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throughputs approaching 1 MIPS per MHz, balancing power consumption and processing speed.

The ATtiny104 device is a small, very versatile, low-cost, easy-to-use microcontroller suited to almaost any application. It can
be used for system monitoring, battery measurement, battery charging, voltage measurement, current measurement,
interface to buttons, switches, drive of small motors, drive of one or more LEDs, and more. The integrated USART provides
means for wired or wireless interface, making it possible to make a powerful, yet small and low-cost solution for any Internet

of Things (IoT) end-node.

Key Parameters

Parameter
Flash {kBytes):

Pin Count:
Max. Operating Freg. {(MHz):
CPU:

# of Touch Channels:

Hardware QTouch Acquisition:

Max I/0 Pins:
Ext Interrupts:
USE Speed:
USB Interface:
© More

Value
1 kBytes

14

12 MHz
8-bit AVR
0

Ma

12

12

Mo

Mo

The ATtiny102 product webpage is available at the following link : http://www.atmel.com/devices/
ATTINY102.aspx

The product webpage has five tabs to provide specific information related to the device.

Atmel

The Overview tab provides the basic information related to the device such as Key Parameters,
Datasheet, link to buy the device, etc.
ATtiny102: http://www.atmel.com/devices/ATTINY 102.aspx?tab=overview

ATtiny104: http://www.atmel.com/devices/ATTINY104.aspx?tab=overview
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+  The Parameters tab provides the details of various configuration parameters for the device.
ATtiny102; http://www.atmel.com/devices/ATTINY102.aspx?tab=parameters

ATtiny104: http://www.atmel.com/devices/ATTINY 104.aspx?tab=parameters

«  The Tools tab - all the related tools such as IDE, Programmer, Debugger, Evaluation Kits, and
BSDL files are listed. This tab features the link to ATtiny104 Xplained Nano kit's webpage.
ATtiny102; http://www.atmel.com/devices/ATTINY 102.aspx?tab=tools

ATtiny104: http://www.atmel.com/devices/ATTINY 104.aspx?tab=tools

«  The Documents tab provides all the related documents such as datasheet and application notes.
ATtiny102: http://www.atmel.com/devices/ATTINY 102.aspx?tab=documents
ATtiny104: http://www.atmel.com/devices/ATTINY104.aspx?tab=documents

— The Datasheet section contains two types of datasheets:
Preliminary/Complete version includes all peripheral descriptions and electrical
characteristics.

Preliminary Summary/Summary version includes ordering information, pin out, and packaging
information.

— The Application Notes section has the device related Application Notes such as Peripheral
Usage, Getting Started, Hardware design considerations, etc., and its associated firmware (if
available).

*  The Applications tab provides the recommended application areas (not limited to) for this device.
ATtiny102: http://www.atmel.com/devices/ATTINY 102.aspx?tab=applications

ATtiny104: http://www.atmel.com/devices/ATTINY 104.aspx?tab=applications

1.3. ATtiny104 Xplained Nano Kit
The details about ATtiny104 Xplained Nano Kit is available in the following link.

http://www.atmel.com/tools/ATTINY 104-XNANO.aspx

Device Ordering Information is available in the bottom section of the page.
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Figure 1-2. ATtiny104 Xplained Nano Webpage

Overview

Devices

Documents

Applications Related Teols

The Atmel® ATTINY104-XNANO Xplained Nano evaluation kit is a hardware platform
for evaluating ATtiny102/ATtiny104 microcontrollers.

Supported by the Atmel Studio free integrated development platform, the kit provides
easy access to all device I/0, one button, and one LED.

The Xplained Mano evaluation kit includes an on-board programmer, and no external
tools are necessary to program the ATtiny104 host MCU that drives the board. The
onboard programmer can be completely disconnected from the host MCU or it can be
used to program any other MCU with the Tiny Programming Interface (TPI).

Key Features

« Atmel ATtiny104 host 14-pin 1kB Flash MCU
«» Embedded programmer for programming the host MCU
+« One mechanical button

« One LED

« Access to all I/0 lines

Ordering Information

Get Started

we'll tell you all you need to know
to start evaluating and working
with this product.

= Start Now ]
= Contact Sales ]
» Request Samples u
» Sign-up for News u

Related ltems

# Third Party Support
% University Program

# AVR Knowledge Base
# Technical Support
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Ordering Code Atmel Store Availability! Unit Price? Buy Online
¥ k4 k4 ¥ [
ATTINY104-XNANO 0 Varies Check Distributor

1Bac.l-dog orders can I:le_placed-F;J'r items currently not available.
25uggested retail price per unit for budgetary use only.

Documents tab displays the kit related documents such as schematics and user guides.

Atmel
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http://www.atmel.com/tools/ATTINY 104-XNANO.aspx?tab=documents
Note: For detailed information about the kit such as headers and connections, refer to ATtiny104
Xplained Nano User Guide.

1.4. Atmel Studio

1.4.1. Atmel Studio Webpage

The Atmel Studio (free IDE) installer is available at:

http://www.atmel.com/tools/ATMELSTUDIO.aspx

1.4.2. Atmel Studio Microsite
To learn more about Atmel Studio, refer to the following microsite:

http://www.atmel.com/microsite/atmel-studio/
Figure 1-3. Atmel Studio Microsite Webpage

Overview ‘ Software QTouch Tools C/C++ Compiler/Editor Debugging/Simulation Videos

Atmel Studio 7

Easier to Use and
More Powerful than Ever

DOWNLOAD NOW @

Atmel Studio 7 - Easier to Use and More Powerful Than Ever

What's New in Atmel Studio 7

f-' 2 §37:
*

Say hello to a cleaner, more modern user interface. '(I':jjom; R Tabisiinie)
Atmel® Studio 7 has been updated to use the 2015 version of the Visual Studio Shell, enhancing

not only the look and feel of the integrated development environment (IDE) but also the ﬁ'ﬁ-
performance when working with large projects. An improved Help system enables better
integration of Atmel documentation in the online as well as the offline help systems. The start [
page has been revamped to always contain relevant and up-to-date information on the devices
you are using to create designs. An updated Visual Assist plug-in included free in Atmel Studio
also brings several improvements and productivity enhancements to the editor. Atmel Studio 7

In the Videos tab the getting started videos such as creating a new C (GCC) project, debugging AVR
applications, debugging ARM® applications, etc. are available.

http://www.atmel.com/Microsite/atmel-studio/videos.aspx

1.5. Connecting the ATtiny104 Xplained Nano Kit
This section helps the user to connect the ATtiny104 Xplained Nano with the Atmel Studio 7.

1. Download and install Atmel Studio 7 or later versions.
2. Launch the Atmel Studio application.
3. Connect the ATtiny104 Xplained Nano to the USB port and it will be visible in the Atmel Studio.
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1.5.1.  Auto Board Identification of Xplained Nano Kit
* When the ATtiny104 Xplained Nano kit is connected to the PC, the Windows® Task bar will pop-up
a message, as displayed in the following screenshot.
Figure 1-4. ATtiny104 Xplained Nano Driver Installation

"_'! Driver Software Installation Y -

mEDBG Virtual COM Port (COMAG) installed

mEDBG Virtual COM Port (COM4B8) JReady to use

Close

k, r

«  If the driver installation is successful, MEDBG will be listed in the Device Manager, as displayed in
the following screenshot.
Figure 1-5. Successful mEDBG Driver Installation
4% CHELT0229
[ @ Batteries

b e Bluetooth Radies
[» {8 Computer

[» v Disk drives

; ‘g, Display adapters

- DVD/CD-ROM drives
l:% Human Interface Devices
ﬁ Imaging devices

A

-

¥ Jungo Connectivity
<= Keyboards

-

--ﬂ Mice and other pointing devices

l_:_l. Monitors

a ¥ Network adapters

Bluetooth Device (Personal Area Metwork) #2
Bluetooth Device (RFCOMM Protocol TDI) #2
----- vy Cisco Systems VPN Adapter for 64-bit Windows
Intel(R) Centrino(R) Advanced-MN 6235
Intel(R) Ethernet Connection [217-LM

----- k¥ Microsoft Virtual WiFi Miniport Adapter

----- EF Microsoft Virtual WiFi Miniport Adapter 2
a3 Other devices

----- g 5M Bus Controller

----- .U.‘i-' Universal Serial Bus (U5SB) Controller

..... g Unknown device

475 Ports (COM & LPT)

-

-

"= mEDBG Virtual COM Port (COM4E) |
i ¥ Processors

& T SD host adapters

b % Seund, video and game controllers

b 4F Storage controllers
[> {8 System devices
[5 i Universal Serial Bus controllers

. Launch Atmel Studio.

*  Go to View > Available Atmel Tools. The mEDBG should get listed in the tools as mEDBG and
the tool status should display as Connected. This indicates that the tool is communicating as
expected with the Atmel Studio.
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Figure 1-6. mEDBG under Available Atmel Tools

Available Tools * 0O X
Tools and Simulators Status
m mEDBG (ATML2G678010200000044) Connected

8 Simulator Connected

1.5.2. Connect the ATtiny104 Xplained Nano UART to the mEDBG COM Port
1. Connect the mEDBG USB to the PC.

2. Use the Device Manager to find the COM port number.

3. Default COM port settings are 9600 baud N 8 1. The COM port settings can be changed by using
the Device Manager.
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2. Creating an Example Application in Atmel Studio

To create a new project in Atmel Studio after connecting the ATtiny104 Xplained Nano:

1. Goto File > New > Project (Ctrl+Shift+N).
Figure 2-1. Creating New Project in Atmel Studio

[E] atting104_LedToggle - Atmelstudic

File | Edit View  VAssist{ ASF Project Build Debug Tools Window

New
Open
Add
Close

E  Close Solution

Help
| {3 Project. k Ctrl+Shift+N
P File. Ctrl+N
4 Atmel Start Configurator
8] EBample Project... Ctrl+Shift+E

2. Inthe New Project wizard displayed, select the GCC C executable Project template, name the
project, and click OK to get the device selection wizard.
Figure 2-2. New Project Wizard
[New Project [
b Recent Sort by: | Default B E Search Installed Templates (Ctrl+E) O ~
4 Installed 6CC C ASF Board Project Cicer Type: C/C++
C/C++ Creates an AVR 8-bit or AVR/ARM 32-bit C
i::gizm oo . GCC C Executable Project C/C++ project
GCC C Static Library Project C/C++
GCC C++ Executable Project C/Cr+
3.

list and click OK.
Figure 2-3. Device Selection Wizard

The Device Selection wizard appears as follows. Select the ATtiny104 device from the drop-down

F B
mEDBG (ATML2678010200000044) - Device Programming (2 [

Tool Device

ATtinyl04

Interface settings
Tool information

Tool settings

Device information
Memories
Fuses

Lock bits

Production file

Reading device ID...0K

[+] Reading device ID..OK

h

Close

Interface Device signature Target Voltage

- [ ) () oaswo |Gl sov [re) (@

This interface has no settings.

4. The new project and the main. c file will be created.
5. Add the following code snippet (LED control using push button) in the main. c file.

int main (void)

{

/* enable the pull-up function */

PUEB |= 1<<PORTB1;

AtmeL Atmel AT12489: Getting Started with Atmel ATtiny102 and ATtiny104 [APPLICATION NOTE]
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6.

Atmel

/* enable pull-up for button */
PORTB |= 1<<PORTRB1;

/* configure LED pin as output */
DDRA |= 1<<DDRAS5;
while (1)
{
/* check the button status (press - 0 , release - 1 ) */
if (! (PINB & (1<<PINB1)))
{
/*switch on the LED until button is pressed */
PORTA &= ~ (1<<PORTAS5) ;

}

else

{
/* switch off the LED if button is released*/
PORTA |= 1<<PORTAS5;

}

}

The project and the main. c file with the code snippet appears as shown.
Figure 2-4. Project Window

ATtiny108_LedToggle - AtmelStudio Mormal Mode Y2 | Quick Launch (Ctrl+Q) Pl O x
File Edit View VAssist{ ASF  Project Build Debug Tools Window Help
‘e-0|B-E -2 RN XTalT -0 | & b K Release ~| Debug Browser - |mliEs|="
LN Pt @i n T H B R oG] o o F e ATEnyl0s Z
main.c B X ~ | Solution Explorer > X
2 mainwhile.if - 2|2 (PINB & (1<<PINE1))) -|&"Go & o-am p-=
i i e
#include <avr/io.h> T B scarch Solution Explorer (Cirl+3) P
-
=lint main(veoid Solution 'ATtinyl04_LedToggle' (1 project)
y! 99 proj
4 ATtiny104_LedToggle
/* enable the pull-up function */ b 4] Dependencies
PUEB |= 1<<PORTB1; b =) Output Files
/* enable pull-up for button */ 4 ﬂ lelrar\as
<] main.c

PORTE |= 1<<PORTB1;

/* configure LED pin as output */
DDRA |= 1¢<DDRAS;
while{1)

/* check the butten status (press - @ , release - 1 ) */

iF(1(PINB & (1<<PINB1)))

/*switch on the LED until button is pressed */
PORTA &= ~(1<<PORTAS);

}

else

{
/* switch off the LED if button is released*/
PORTA |= 1<<PORTAS;

}

Solution Explorer JIRTEES

Qutput

Ready Col 10

Code explanation:
— The application uses the mechanical button and yellow LED of ATtiny104 Xplained Nano kit.
They are connected to Port Pin PB1 and PA5, respectively.

— Each PORT has three registers; DDRx, PORTXx, and PINx.
— The DDRXx register is used to configure the port pin direction.
« 1-Output
*  0-Input
— The kit does not have pull-up resisters onboard and hence internal pull-up has to be enabled
for the button.
— Configure the PUEX register to enable internal pull-up of the corresponding port pin.

Atmel AT12489: Getting Started with Atmel ATtiny102 and ATtiny104 [APPLICATION NOTE] 1"
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— When a pin is configured as input and the respective bit in PORTXx is written logic one, the
respective pin is internally pulled up.

— The PINx register is used to return the logic level available on the port pin.

— The button connected to pin PB1 is configured as input with pull-up enabled. LED connected
to Pin PA5 is configured as output.
— The LED is controlled based on the button status. When the button is not pressed the LED
will not glow. When pressing the button the LED will glow.
8. Go to Build > Build Solution (F7) to compile the project.

9.  When the code is compiled successfully, go to Tools > Device Programming (Ctrl+Shift+P).

10. Select the Tool (as mEDBG), Device (as ATtiny104), and Interface (as TPI). Click Apply.
Figure 2-5. Tool and Interface Settings

g ™
mEDBG (ATML2678010200000044) - Device Programming 7 [t
Teol Device Interface Device signature Target Veoltage
mEDBG ~ | ATtiny104 - Apply|  Ox1ES008 50V %
Interface settings

Tool information

Tool settings

Device information o )
: This interface has no settings.

Memories

Fuzes

Lock bits

Production file

Reading device ID...0K

[+] Reading device ID..OK

Close

11. Read the Device Signature and Target Voltage to ensure proper connection.
12. In the Device Programming window, go to Memories Tab. Click Erase now to erase the device.
13. To program the device with the hex file, browse the *.hex/elf file location and click Program.

b
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Figure 2-6. Tool and Interface Settings

Tool information

Tool settings

Device information
Memories
Fuzes

Lock bits

Production file

Reading device ID...0K

(] ok

b

P' ™
mEDBG (ATML2678010200000044) - Device Programming 7 [t
Teol Device Interface Device signature Target Veoltage
mEDBG ~ | ATtiny104 - Apply|  0x1E9008 Read| 50V %
Interface settings Device

[EraseChfp 'H Erase now ]

Flash (1 KB)

Erase Flash before programmin
Verify Flash after programming
v | Advanced

14. The working of the application can be tested manually. The LED shall turn ON when the button is
pressed and turns OFF when the button is released.
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3. What’s Next?

Atmel

Atmel Studio videos
http://www.atmel.com/Microsite/atmel-studio/videos.aspx

Atmel Studio online help
http://www.atmel.com/webdoc/atmelstudio/

Atmel Studio offline help (after installing Atmel Studio)

Open Atmel Studio, Help > View Help (Ctrl+F1) > Atmel Studio
ASF (Atmel Software framework) Getting Started and ASF Reference manual
http://www.atmel.com/tools/AVRSOFTWAREFRAMEWORK .aspx?tab=documents
ASF online documentation

http://asf.atmel.com/docs/latest/

Technical documentation for various products
http://www.atmel.com/webdoc/

Atmel Gallery

https://gallery.atmel.com/

Production Selection Guide

Atmel MCU Selector on http://www.atmel.com/

Ordering samples and buying evaluation board and kits:
http://www.atmel.com/. Go to Buy > Atmel store

Technical documentation
http://www.atmel.com/design-support/documentation/default.aspx
Knowledge base and technical support/design support
http://www.atmel.com/design-support/

Collaborative workspace

http://spaces.atmel.com

AVR Freaks® community

http://www.avrfreaks.net/
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4. Revision History

Doc. Rev. Date Comments

42678A 02/2016 | Initial document release
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an Atmel officer's specific written consent. Safety-Critical Applications include, without limitation, life support devices and systems, equipment or systems for the
operation of nuclear facilities and weapons systems. Atmel products are not designed nor intended for use in military or aerospace applications or environments
unless specifically designated by Atmel as military-grade. Atmel products are not designed nor intended for use in automotive applications unless specifically
designated by Atmel as automotive-grade.


https://www.facebook.com/AtmelCorporation
https://twitter.com/Atmel
http://www.linkedin.com/company/atmel-corporation
https://plus.google.com/106109247591403112418/posts
http://www.youtube.com/user/AtmelCorporation
http://en.wikipedia.org/wiki/Atmel
http://www.atmel.com
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